CTP nightmares...

When I inherited a number of 2005 instances that had been service packed with the CTP version of SP2 ( 9.00.3033.00 ). I thought no problem, I’ll just run SP2 GDR1 hotfix and that should sort the problem. After all microsoft appeared to make a clear migration path for its various versions of SP2 ( http://blogs.msdn.com/psssql/archive/2007/04/06/post-sql-server-2005-service-pack-2-sp2-fixes-explained.aspx ).  However on running the GDR1 hotfix it I got this error:

The product instance XXXX has had update 3033 applied. You cannot install GDR update 3054 overtop update 3033. An update of build equal to or greater than 3159 should be downloaded.

So ah ha I thought ok I’ll install GDR2 which should do the trick, then I find the error:

The product instance XXXX has had update 3033 applied. You cannot install GDR update 3159 overtop update 3033. An update of build equal to or greater than 3042 should be downloaded.

A bit long winded I know but in the end, I found the solution to be just to install the downloadable version of SP2 ( http://www.microsoft.com/downloads/details.aspx?FamilyId=d07219b2-1e23-49c8-8f0c-63fa18f26d3a&displaylang=en ) .

As a general warning to anyone out there I would strongly advise against running CTP versions of software on production systems (or even your workstation!) . I still recall the nightmares with Sql 2005 CTP beta release 2 eventually forcing me to rebuild my workstation after wasting a lot of time trying to uninstall .net and frig around with various system settings…..

 

Published 26 June 2008 14:02 by blakmk
Filed under:

Comments

No Comments